linux系统升级gcc编译器(升级到gcc4.8以上)

1、安装依赖包
  1. yum install glibc-static libstdc++-static
2、下载源码

可以去gnu官网查看适合的版本:http://ftp.gnu.org/gnu/gcc/

  1. wget http://ftp.gnu.org/gnu/gcc/gcc-4.8.5/gcc-4.8.5.tar.gz
3、配置
  1. tar -zxvf gcc-4.8.5.tar.gz
  2. cd gcc-4.8.5
  3. ./contrib/download_prerequisites #这一步可以下载gcc需要的依赖包
  4. mkdir gcc-build-4.8.5
  5. cd gcc-build-4.8.5
  6. ../configure --enable-checking=release --enable-languages=c,c++ --disable-multilib
4、编译
  1. make -j4

编译时间可能比较长,需要耐心等待

5、安装
  1. make install
6、重启系统查看gcc版本
  1. gcc -v